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Abstract

This presentation describes how to run the simulation
demonstration of a Quadrature (1/Q) Mixer using
eightolives Schematic Mobile and WaveformViewer.

The schematic Is opened in eightolives' Schematic
Mobile and then the menu command “View
Waveforms” opens the design in WaveformViewer.

The circuit Is usable as part of a Software Defined
Receiver (SDR) design. The example shows the

Intended digital clocking waveforms and sampled

outputs.
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Background

» A Quadrature Mixer is a building block for
radios. Sampling radio signals with two
waveforms 90 degrees out of phase allows
further processing elements to eliminate

unwanted mixer products.

Input RF signal >©—>

T In-phase Mixer output
Variable | ( > |
Clock T Quadrature Mixer output
—» 90 degree
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Circuit Overview

N C |  The mixer consists of 2 — 4 to
/:@—’ o 1 differential analog selectors

QIN that are controlled by a low-
SDA \ / jitter programmable clock
=<k Programmable oscillator feeding a
s1 IQ Osc programmable clock divider
chain.

« Key components

. D flip-flop chains allow use of
 Silicon Labs SI-570

three frequency ranges
P ble XO :
rogramman’e covering 10 Khz to 40 MHz
 T.I. TS3A5017

. Linear Tech LT3007 linear voltage  * NO INPuUt or output filtering is
regulator Included
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Specifications

* Input Power: 5 VDC * |nput signals

« Analog infout: 0 — 3V * IIN_P, IIN_N (0 -3 V)

« QIN_P, QIN_N (0-3V)
 SDA, SCL (12C serial)

e Mixer osc ranges

S1, SO Fmixmin Fminmax

(Si 570) 10 MHz 160 MHz e« S1, S1(LVTTL)
0,0 14 2.5 MHz 40 MHz .

1,0 164 156 KHz 2.5 MHz * OUtDUt Slgna|5
1,1 /1024 10 KHz 156 KHz o | p, | N (O _ 3\/)

c Q PQN(@O-3V)
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Sheet 1: Clock Generation
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Sheet 2: Switching Mixers
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First, start Schematic Mobile

« Schematic Mobile is tested with Firefox, Safari
and Chrome web browsers

* You can open it from:

* Eightolives Home: http://www.eightolives.com

« Eightolives' QuickApps menu

- http://www.eightolives.com/docs/Mobile/navigate/jstools.htm
* Directly:

- http://lwww.eightolives.com/docs/Schematic/SchematicM.htm
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Next, click the Design menu, select Open Project

a eightolives Schematic - Mozilla Firefox I Gl 6.5

-~ eightolives Schematic x |

€ eightolives.com v

Open Project
| Open Project File
Save Project

eightgolives Schematic

ce | aim | | v | v | - N Sheet
ew Shee
1
Open File (FS)

== | Upload File
| Delete Sheet 1
= Fix Refdes
= Update Nets
— Check Design

Generate BOM
Generate Netlist

Save Sheet (FS)
Save Sheet Local
Save Sheet Preview
Email Sheet

View Waveforms

Print Preview

Close

o]

X =[s00 mils; Y = |s500 mils

javascript:menu('Design') = 9
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Select “Server” service

-
4

Open Project

Select Service:
OLOCAL

® Server

O External service |
O Drive

Select Project:

Demo Dog Tag

Example of Using a Bus

Picture in Schematic

Simulation Example 1 SR Flip Flop
simulation Example 2 Counter circuit
Quadrature Mixer circuit ~

Copyright © 2015 William Kaupinis All Rights Reserved

 Then from the Select
Project drop-down
window select
“Quadrature Mixer
circuit”

 Then click the Select
button.
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Next, select Design > Open Project File

» Select sheet 1 then
click the Open button

Open Project File « Wait for the sheet to
Open file load then open sheet 2

* When you load a sheet,

;- Mixer - sheet 1 Schemal:lc 7
Quad Mixer - sheet 2 Schematic the orlglnal, empty

Hardware model sheet 1 is retained so

VCD signal File
the new sheets appear

as sheet 2 and 3

Copyright © 2015 William Kaupinis All Rights Reserved
11



-
]

Open Project

Save Project

Open Project File |

New Sheet

Open File (FS)

Upload File

// Delete Sheet 1
)

Fix Refdes
Update Nets

Check Design

\\\ Generate BOM
Generate Netlist

Save Sheet (FS)

Email Sheet
View Waveforms

Save Sheet Local
Save Sheet Preview

Print Preview

Close

eightolives.com

Clean up and checks

Using the Design Menu, click “Delete Sheet
1” to delete the empty original sheet

Click “Fix Refdes” to check and correct any
refdes issues

Click “Update Nets” to check all net
connections

Click “Check Design” to perform checks and
see results in the Report Window at the
bottom of the page (or also in a popup
window in some browsers)

Copyright © 2015 William Kaupinis All Rights Reserved
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The Check Design Report

Check Design 5/6/15

* NO errors are reported
Nets OK

Check Sheet 5/6/15

» The reported

1: SHEET 1 OF 2

Comment: U1l-1 NC has no connected signal

L} L]
Warning: U1-5 CLK_N has no connected signal W rn I n r f r I n
Warning: J1-6 P6 has no connected signal
Warning: J1-7 P7 has no connected signal
Warning: U4a-6 ON has no connected signal

Warning: U4b-9 Q has no connected signal th at h ave n O

Check Sheet 1 0K
5 warnings.

e s 51 connections.

QUADRATURE_MIXER
2: SHEET 2

Warning: U9-4 512 has no connected signal

L] L}
Warning: U9-5 S11 has no connected signal ) S I n Ce It refl eCtS th e
Warning: U9-12 S22 has no connected signal
Warning: U9-11 521 has no connected signal
Warning: U1@-3 513 has no connected signal

L L]
Warning: U1@-6 516 has no connected signal !
Warning: U18-13 523 has no connected signal
Warning: U1@8-1@ 520 has no connected signal ]

ek shes 3 0 continue on.

Check Design 0K
13 warnings.

Copyright © 2015 William Kaupinis All Rights Reserved
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To start WaveformViewer

 For this demonstration, it is easiest to click
Schematic Mobile's Design > View Waveforms
menu option

* You will be prompted to save the eightolives'
Hardware Model of the design,
QUADRATURE_MIXER.js

* Click OK

Copyright © 2015 William Kaupinis All Rights Reserved
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WaveformViewer will start

e v eightolives WaveformViewer - Mozilla Firefox ) o) X

7 g
- eightolives Schematic = | - eightolives Wavefor... = '-.\+

@ r’:y-www.eightolives.com,-’docs,-’waueformViewer,fwaveformUieu.fer.htm?pzht'C‘||Q Search | B ¥ A 44 66 =

Set QUADRATURE_MIXER as TopElement?
psq

Cancel

Click OK to set
QUADRATURE_MIXER as the
top element to simulate.

When loaded, the design name
appears below the time line.
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Click File > Open Project File

Open Project File

RN I N
Open Project
Dpengnject File
Save LD

Open file:

Quad Mixer - sheet 1 Schematic
Quad Mixer - sheet 2 Schematic
Hardware model

Open File (FS)

Check Simulatabl
eck Simulatable » Select the VCD (Value

S Change Dump) file entry and
Save VCD Preview click the Open button. This

Print Preview

Close

stimulus on the inputs.

Copyright © 2015 William Kaupinis All Rights Reserved

loads a set of signals to
monitor and sets predefined
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WaveformViewer with VCD file loaded

Left Side Buttons
Zoom In

Zoom Out
Pan Left

Pan Right

Restart
Load VCD File
Add to Sim Queue
Run

Run For
Single Step

Stop

2 eightolives WaveformViewer - Mozilla Firefox
eightolives Schematic = eightolives Wavefor... x | ¢
eightolives.com - w B ¥+
D File Edit Sim Pref Help
e [a o o [E (| [

QUADRATURE_MIXER

Cursor 1 |0 _|O

Report:

Welcome to eightolives WaveformViewer
getService http://www.eightolives.com/docs/
PROJECT LIB = LOCAL -1 null

loadinitl p=http://www.eightolives.com
Jdocs/MWaveformViewer/sim3/,
d=0UAQRATURE_MIXER.]js, a=null
openf~fojectFileByName a
http://www.eightolives.com

J/docs /WaveformViewer,/sim3/QUADRATURE MIXER.js
Service openFile http://www.eightolives.com

Copyright © 2015 William Kaupinis All Rights Reserved
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About the Stimulus

* The provided stimulus file puts fixed (DC) logic values on the |
and Q differential inputs.

 The VPWR input is pulsed low at the beginning since some
simulation models use power being low as a condition to reset
(for simulation only)

 The S1 and SO divider control lines start at 0,0 and later
changed to 1,0 and then 1,1 to demonstrate the three operating
ranges. The full sim requires about 150 us of sim time. This sim
IS not self-terminating and will run to Max Sim Time.

* The default Max Sim Time is 5 us so that preference will need
to be modified to view all three ranges.

Copyright © 2015 William Kaupinis All Rights Reserved
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Run the Sim

e Click the “+” button to add the stimulus to the sim
gueue

» Click the green “>>" button to run the sim.
* The sim will stop at the default Max Sim Time of 5 us

The blue cursor shows the
end of the sim.

| P and |_N outputs show
the mixing of the “DC”
iInputs with the mixing
frequency.

Setting S1to '1'at 2.8 us
causes the frequency

Copyright © 2015 William Kaupinis All Rights Reserved
PYIS g ] range to change.
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Set Max Sim Time to 150 us

e From the Preferences menu select “set Max
Sim Time” and enter 150 us in the dialog box.

* Restart the simulation using the Restart
seguence shown in the next slide.

* Notice that the simulation proceeds in “chunks”
of 1 us of sim time

Copyright © 2015 William Kaupinis All Rights Reserved
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To rerun a simulation

 Click the Restart button (“<<”

» Click the Load VCD button (“v”) If you want to
reload the last VCD stimulus file

» Edit the waveform stimulus if you wish

» Click the (“+”) button to add the stimulus to the
simulation queue

» Click the Run button (*>>"

* Click the Run For button (“>") for a specific run time

Copyright © 2015 William Kaupinis All Rights Reserved
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What the Mixer Does

ey ey ey ey ey ey e,

ey ey ey e e, e, e,

« PHASEI is similar to a sine wave and PHASEQ is similar
to a cosine wave with respect to phase

* Note that the | and Q outputs sample the mixed input
values out of phase based on the PHASEI and PHASEQ

values

Copyright © 2015 William Kaupinis All Rights Reserved
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* |n an SDR receliver application, the outputs
would typically be filtered and then further
processed by analog circuits or converted to
digital signals and be processed digitally

RFIN —» —» Filter ——» AD —»

> Mixer DSP
—» —» Filter ——» A/D | »

Copyright © 2015 William Kaupinis All Rights Reserved
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Results

* The simulation shows that the clocks for the 3
frequency bands have the correct phase
relation.

* |t shows the mixer outputs behaving as
expected.

Copyright © 2015 William Kaupinis All Rights Reserved
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About Chunk Time

* Browsers execute Javascript in a single thread.

 In order to be responsive to user input and avoid browser
timeouts, a long simulation run is divided into smaller chunks
separated by a Pause Time.

« WaveformViewer's default chunk is 1 us of sim time
 The default PauseTime between chunks is 1000 ms (1 sec)
e Both items can be changed via Preferences > Set Sim Chunk
Timing
 If a chunk takes too long to execute (> 10 sec), the browser

may report a non-responsive script which you may continue
or halt.

Copyright © 2015 William Kaupinis All Rights Reserved
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Alternate way to start this sim

* You can also do this sim directly from
WaveformViewer

* http://www.eightolives.com/docs/WaveformViewer/\WaveformViewer.htm

* Or from the eightolives QuickApps menu

* File > Open Project, select Server service and
then select the Quadrature Mixer project

* File > Open Project File and select the
Hardware Model to open

Copyright © 2015 William Kaupinis All Rights Reserved
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For more information

* Check tutorials at: http://www.eightolives.com

* Using Schematic Mobile
» Using WaveformViewer
» eightolives Hardware Model API (version 2)

Copyright © 2015 William Kaupinis All Rights Reserved
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